summaryrefslogtreecommitdiff
path: root/dev-util/diffball/diffball-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diffball/diffball-1.0.1.ebuild')
-rw-r--r--dev-util/diffball/diffball-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/diffball/diffball-1.0.1.ebuild b/dev-util/diffball/diffball-1.0.1.ebuild
new file mode 100644
index 000000000000..0902b00c14f9
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://diffball.googlecode.com/"
+SRC_URI="https://diffball.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+}
+
+src_configure() {
+ econf $(use_enable debug asserts)
+}