summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-288.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 96054d540a49..9527029ce6ee 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,7 +1,9 @@
DIST diffoscope-284.tar.bz2 3149578 BLAKE2B 4969e394a32d076101d59c0ca730d4e3515e1f3c60031705aed7c043ea031442829435e20de9723117ab73a08b6eef81d97eb8f92f225eb7d9c702bc0060c1ca SHA512 c3a6e02340873e71a4b75412848d9878f3e63c4db14f1ed128744feff2240d688336bcd83b121dcfa8c12e332cb00fdfe0ae347cd5a88e4ec29b3591263e3f65
DIST diffoscope-285.tar.bz2 3151919 BLAKE2B ad7c20368f8d3747b8b092d8761d6596809e39ee6ba09115e15f3b6c32da7e3cc590eed5628fb07cfc1fcf2f3b56ee7a4c3fd920c413e7f9e7a0522dfc6c721c SHA512 4b2eb41ddfee687408377185fb0ff5e88d6956c09a4dfceceb7c136596a3b00192be949c141f16f47e90f58da2f9ee1f51cd020f688e1bd6048462f357f14a03
DIST diffoscope-286.tar.bz2 3155046 BLAKE2B 20676f44d6722962aed53351c006a538d2ac1d20bb2f38edc6f4bbf0e09d28de80d72045db3f9c1ed95c3b3156f40f995962a8510e8c01e0c21900df9a335489 SHA512 42d47801f0dc6cf66f3261639040dd82c5fde73656ab1a33dad325383e4bc6351d03c7509661172c946f554136ea23bf9b6787ba736138461690e507097dc133
+DIST diffoscope-288.tar.bz2 3157674 BLAKE2B 546cf9cca9ca1f81470cfa347517054cc00a5195eb90b3aa72b6fdfde23e1385d4264f6c2c3b3c462a8ef4547fc136c6c758e240423deecb0689721057786bac SHA512 c93849f6bfa7173981b783e68114dfda44938629d5152ce67751b341ce3153c9dbc188dbf95c6d3bc69bfc3d303ab081db70ac37c5e30def3b364351ffd9d88b
EBUILD diffoscope-284.ebuild 3937 BLAKE2B 38da064a3715a2c13b3a674416dc4ef91b39024e81ee13e01ff1ef788a988a5c946ec363df8d6b62cf11609a830c592e68c84a04f0f7d2fe9822e37c9d4be28d SHA512 97537df18723a72b2e91390bf7f4406b38b864ac695795597874686f360307841ea570a3d60ca11c94c0efe0fe13ec888699fe46d7fee21e639ef0674b4ce9c2
EBUILD diffoscope-285.ebuild 3938 BLAKE2B 1fe168439f96d6c496b2ebcc7352b6d35a7d4f9348e86639e93825a15d7aaa1564f89ce67d58ec31848d64f19d8f48266b5b57c20f121d0a0f3bc2e8fab0a820 SHA512 a580e39916e09c66bb9d243347654cb69850d2feaf64e7144254b07be4a614bfec562e952bed52cec7d81fbf7f8406e9d72f5ab2d99f888655c8ed6552336e2e
EBUILD diffoscope-286.ebuild 3938 BLAKE2B 1fe168439f96d6c496b2ebcc7352b6d35a7d4f9348e86639e93825a15d7aaa1564f89ce67d58ec31848d64f19d8f48266b5b57c20f121d0a0f3bc2e8fab0a820 SHA512 a580e39916e09c66bb9d243347654cb69850d2feaf64e7144254b07be4a614bfec562e952bed52cec7d81fbf7f8406e9d72f5ab2d99f888655c8ed6552336e2e
+EBUILD diffoscope-288.ebuild 3938 BLAKE2B 1fe168439f96d6c496b2ebcc7352b6d35a7d4f9348e86639e93825a15d7aaa1564f89ce67d58ec31848d64f19d8f48266b5b57c20f121d0a0f3bc2e8fab0a820 SHA512 a580e39916e09c66bb9d243347654cb69850d2feaf64e7144254b07be4a614bfec562e952bed52cec7d81fbf7f8406e9d72f5ab2d99f888655c8ed6552336e2e
MISC metadata.xml 2086 BLAKE2B 75fdcf3b9bb7b9dd6222f07a04a96b2166c9a819ca5c6358daf4451bf73951b443596e05548ebdc163338eafbc75574e47635b3920ee8125690a310bf5185cf2 SHA512 552933e0c0e9cf23a8f3435a2587c6738f26e5153d773a745159ab1623ad5f39ef5d2647368918b9fdb25d61aab6a02a860c0f815740c1b70c973aa0a48a11ce
diff --git a/dev-util/diffoscope/diffoscope-288.ebuild b/dev-util/diffoscope/diffoscope-288.ebuild
new file mode 100644
index 000000000000..6f5fc7ca5b80
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-288.ebuild
@@ -0,0 +1,140 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+# We could use pypi, but upstream provide distribution tarballs, so let's use those.
+# TODO: verify-sig
+SRC_URI="https://diffoscope.org/archive/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/python-tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-alternatives/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( llvm-core/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/pypdf[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( virtual/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-arch/p7zip
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ #tests/comparators/test_macho.py::test_llvm_diff
+ #tests/comparators/test_elf.py::test_libmix_differences
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ case $(tc-get-ptr-size) in
+ 4)
+ EPYTEST_IGNORE+=(
+ # Needs fixing in Perl itself (bug #934443)
+ tests/comparators/test_epub.py
+ tests/comparators/test_zip.py
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ distutils-r1_src_test
+}