summaryrefslogtreecommitdiff
path: root/dev-util/distro-info
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/distro-info')
-rw-r--r--dev-util/distro-info/Manifest4
-rw-r--r--dev-util/distro-info/distro-info-0.14.ebuild94
-rw-r--r--dev-util/distro-info/distro-info-0.22.ebuild2
3 files changed, 2 insertions, 98 deletions
diff --git a/dev-util/distro-info/Manifest b/dev-util/distro-info/Manifest
index fdc5de3db2cf..84a831bace77 100644
--- a/dev-util/distro-info/Manifest
+++ b/dev-util/distro-info/Manifest
@@ -1,5 +1,3 @@
-DIST distro-info_0.14.tar.xz 26460 BLAKE2B eb34e31514f7acfd283ae9405132884ccae31b77d6cf7af3a8a341ac349d589cbd5d7828e763911fc490d6504edae4c90551b3d3cc3518eec1f47ab1dcc6ac60 SHA512 aa0055f21523e30fc7e9c94c92f87cbd05fc5d082ddc109d092e94dabafac7533ced984197797252eb698232b3d8f512b3c345ed6abef0ae074bf2770224955e
DIST distro-info_0.22.tar.xz 29104 BLAKE2B 88eab833ea34de9e62f858e1fb9acfb94efb60114d2213b8bbb77a440c114dbac70a1707d1469113c1a98ea94d953ffa36480c132c294fd8e22b816a444b25e1 SHA512 b9d97e469b9173651c1816f39cc2315622b46f1579cbaba29c417a51417425e90a45283e83c7efee35db78621df08997f5395c8c1b0259f69e5cd91dee65793f
-EBUILD distro-info-0.14.ebuild 1938 BLAKE2B bcdbcc88dc4f5d6ca4d87430755435b09e69dcdd645b7843ee7d37f2b0f32abc5b129a9847218fffc7af20ac89750a873520ed8949c3be614a0846b9b6a6b9f0 SHA512 8fc392ea0ec26dad1f89b17673b07ca71f7d35d623f759fbb66be34d7bb02ebb2f39b50660684281990b46f23fc16cfdb7340542684d4accc2cff21bec1400ed
-EBUILD distro-info-0.22.ebuild 1974 BLAKE2B 1dbe82683b54056c4fcf02342979b18a1c5adb429384686a91f87e716f8f6c3d1e92a6c5bab4fd3cc97d6d660fdc12dd302d0c54ba49fee288d676f91bfe9e26 SHA512 8d42924259c4351ee6ddff973f4af5ce5008e5b1ba80d74ef74f35424460abef15a53830f7c07dac22d763a813760d6a334d60cab81f7629a7b24a9dae95c586
+EBUILD distro-info-0.22.ebuild 1972 BLAKE2B c720d96facd7e4bae3873de432c42092d4a846b76ea76d67c25200451dc3e94f3b06c32c4dbb5b41b7fea861ad8c2ba03df479ebd64e5e0e4d3b3155e4a4b71f SHA512 c93929ed215833f00369ae03b170f38b49c25a260c609ea4712c268c3e4e5a41593c8ed7c477dd665865b9b6c00111a643b4be0560a1a53fff1d390d652e222d
MISC metadata.xml 367 BLAKE2B 867a3664c5bbd444d69af80af19994e07e3810349258e85c2afd0c838cb140aa3f3342ee1aa5e6862d1fd5130e7e09c1f9f30443827fe7df705f4273694c0784 SHA512 3eb0be47e7eb6bfb6d8eecee66a25183da436c38272e226e7819c8748774f3aae620eab7227414cb862734d4baf8fa060290c1b2371233141abcffd7b489c7b8
diff --git a/dev-util/distro-info/distro-info-0.14.ebuild b/dev-util/distro-info/distro-info-0.14.ebuild
deleted file mode 100644
index 11fae490576c..000000000000
--- a/dev-util/distro-info/distro-info-0.14.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-DISTUTILS_OPTIONAL=true
-
-inherit distutils-r1
-
-DESCRIPTION="Provides information about the Debian distributions' releases"
-HOMEPAGE="https://debian.org"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="dev-lang/perl:=
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${CDEPEND}
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
- test? (
- dev-util/shunit2
- dev-python/pylint[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- dev-util/distro-info-data"
-
-src_prepare() {
- default
-
- # 1. Gentoo do not provides dpkg vendor information
- # 2. Strip *FLAGS
- # 3. Strip predefined CFLAGS
- # 4. Point to correct perl's vendorlib
- # 5. Remove python tests - python eclass will be used instead
- sed -e "/cd python && python/d" \
- -e "/VENDOR/d" \
- -e "/dpkg-buildflags/d" \
- -e "s/-g -O2//g" \
- -e "s:\$(PREFIX)/share/perl5/Debian:\$(PERL_VENDORLIB)/Debian:g" \
- -e "/pyversions/d" \
- -i "${S}"/Makefile || die
-}
-
-src_configure() {
- default
-
- if use python; then
- pushd ./python > /dev/null || die
- distutils-r1_src_configure
- popd > /dev/null || die
- fi
-}
-
-src_compile() {
- default
-
- if use python; then
- pushd ./python > /dev/null || die
- distutils-r1_src_compile
- popd > /dev/null || die
- fi
-}
-
-src_install() {
- emake PERL_VENDORLIB=$(perl -e 'require Config; print "$Config::Config{'vendorlib'}\n";') \
- DESTDIR="${D}" install
-
- if use python; then
- pushd ./python > /dev/null || die
- distutils-r1_src_install
- popd > /dev/null || die
- fi
-}
-
-src_test() {
- TZ=UTC default
-
- if use python; then
- python_test() {
- esetup.py test
- }
-
- pushd ./python > /dev/null || die
- distutils-r1_src_test
- popd > /dev/null || die
- fi
-}
diff --git a/dev-util/distro-info/distro-info-0.22.ebuild b/dev-util/distro-info/distro-info-0.22.ebuild
index 7e1a4d02db52..c7530dee8c22 100644
--- a/dev-util/distro-info/distro-info-0.22.ebuild
+++ b/dev-util/distro-info/distro-info-0.22.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="python test"
RESTRICT="!test? ( test )"