summaryrefslogtreecommitdiff
path: root/dev-util/ebuildtester/ebuildtester-42.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ebuildtester/ebuildtester-42.ebuild')
-rw-r--r--dev-util/ebuildtester/ebuildtester-42.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/ebuildtester/ebuildtester-42.ebuild b/dev-util/ebuildtester/ebuildtester-42.ebuild
new file mode 100644
index 000000000000..4222ddc016f2
--- /dev/null
+++ b/dev-util/ebuildtester/ebuildtester-42.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# SRC_URI="https://github.com/nicolasbock/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-containers/docker
+ sys-fs/fuse
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${PN}.bash-completion" "${PN}"
+}