summaryrefslogtreecommitdiff
path: root/dev-util/gef/gef-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gef/gef-9999.ebuild')
-rw-r--r--dev-util/gef/gef-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/gef/gef-9999.ebuild b/dev-util/gef/gef-9999.ebuild
index e29ca85b5b66..f6f2afc9a0ad 100644
--- a/dev-util/gef/gef-9999.ebuild
+++ b/dev-util/gef/gef-9999.ebuild
@@ -10,7 +10,7 @@ inherit python-single-r1 wrapper
DESCRIPTION="A GDB Enhanced Features for exploit devs & reversers"
HOMEPAGE="https://github.com/hugsy/gef"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hugsy/gef"
else
@@ -36,7 +36,11 @@ RDEPEND="
dev-util/unicorn[python,${PYTHON_USEDEP}]
')"
-BDEPEND="doc? ( dev-python/mkdocs )
+BDEPEND="
+ doc? (
+ dev-python/mkdocs
+ dev-python/mkdocs-material
+ )
test? (
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
@@ -47,7 +51,7 @@ BDEPEND="doc? ( dev-python/mkdocs )
src_prepare() {
default
- sed -i -e '/pylint/d' requirements.txt || die
+ sed -i -e '/pylint/d' tests/requirements.txt || die
}
src_compile() {
@@ -56,19 +60,19 @@ src_compile() {
}
src_install() {
- insinto /usr/share/${PN}
+ insinto "/usr/share/${PN}"
doins -r *.py
- python_optimize "${ED}"/usr/share/${PN}
+ python_optimize "${ED}/usr/share/${PN}"
make_wrapper "gdb-gef" \
- "gdb -ex \"source ${EPREFIX}/usr/share/${PN}/gef.py\"" || die
+ "gdb -x \"/usr/share/${PN}/gef.py\"" || die
if use doc; then
# TODO: docs.eclass?
mkdocs build -d html || die
- rm "${WORKDIR}"/${P}/html/sitemap.xml.gz || die
+ rm "${WORKDIR}/${P}/html/sitemap.xml.gz" || die
dodoc -r html/
fi