summaryrefslogtreecommitdiff
path: root/dev-util/gengetopt/gengetopt-2.23-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gengetopt/gengetopt-2.23-r1.ebuild')
-rw-r--r--dev-util/gengetopt/gengetopt-2.23-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/gengetopt/gengetopt-2.23-r1.ebuild b/dev-util/gengetopt/gengetopt-2.23-r1.ebuild
new file mode 100644
index 000000000000..564527128402
--- /dev/null
+++ b/dev-util/gengetopt/gengetopt-2.23-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool to write command line option parsing code for C programs"
+HOMEPAGE="https://www.gnu.org/software/gengetopt/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-apps/texinfo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.22.6-docdirs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' -i configure.ac || die
+ sed -e '/gengetoptdoc_DATA/d' -i Makefile.am || die
+
+ eautoreconf
+}