summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild
new file mode 100644
index 000000000000..3d0bcc6253b9
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.27.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=af7cd633c15d6ec4eacf5a8fb6f8a0c494f7e9ed
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}