summaryrefslogtreecommitdiff
path: root/dev-util/glade
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest2
-rw-r--r--dev-util/glade/glade-3.22.2.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index d836550011f4..c9af3d62ea9b 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,4 +1,6 @@
AUX glade-3.14.1-doc-version.patch 853 BLAKE2B b7cad3cc9d49cfe24189ba21bffaec2c524d3c7953d722b3b03d57ad68297fee6757330c1a2d90f36bcfe52d1d9ef4d95b81eeb19109bc8957f671ac40d31573 SHA512 cc9aec06f6acdfdf538de7043f9f753768e0e4c26fa9eef7e52b4e42aa6fd3836185c18ffd51abfc2aa3e6f5b2472e68914112230d2b8856e8a3c61e9d865ecf
DIST glade-3.22.1.tar.xz 3592952 BLAKE2B 53f769198a093ff5d4dc98bb4ea98c6e5195933caf24247a99db980312ae3398fca3abbd640d08c02e8fb5f8647ee3e4b18e65073b1500e9017ee0586993a331 SHA512 e1bdc49b89bc5010c0abf6357dbae05c921182655b2ee5a4b161af6adfd596cfbcd495c9851ba956abbf3d6156616a6c0e94640cd72cee11551ca388674ac908
+DIST glade-3.22.2.tar.xz 3550008 BLAKE2B e1217e221b36938937c57ae465a3707eeadc52bc9127b3af2fb6514e572676e3e284811d5332876dce110fd321e2bb33b9ac8b0afbd97dd747725eb73309dc15 SHA512 cb82684423ae055bc8e84a8705529ecdc72957563f444633c2c5c24a922130de84c212537323b6ed259f0e29349b52dff608822610b87babb8fc3cb468a5f4b0
EBUILD glade-3.22.1-r1.ebuild 2343 BLAKE2B 93c4d4e44d12d882e611675681a2df462788f5945c09f5b83dfffce1eb4c8d9582e48effa6198aecbb58dd3b66e46c29381764ca152353ea9d8dadfd9316d310 SHA512 3428c28c9dbbbcfa4f8ce3296dea55b22245597d31d6966d74cf530640e2e231f4c94a785df1d2c662b9bfc0353a4a7cacd53a8ca57337d3b9a7f821cfb96e6b
+EBUILD glade-3.22.2.ebuild 2326 BLAKE2B f43ce674c9731f626c27260efcda3c7af3b54ad9a2389e7e1679fa0e31310ca4b430a928214146c1c1293683adac52a1a758507456da54dc099449bdc71cd8de SHA512 96eb27b3ea7b6934f85209ca9ccb9952fe28943321b9037eb1164135590cd421792627826533f0f9b3796cde2d69b28bfbbf18ccd7c051f5a8155d7e29c3e21e
MISC metadata.xml 358 BLAKE2B 33f3b46ab877b311931205095fb2b357fe7fe2da8820944d32e8a16f2dbcf99033f95a17f4cefa4aa6d0f731c72d0f65683a8cc3b947ebf09d084f92e796f887 SHA512 8840ebde12f26a2caf856e75f3f706e3c9a7a7a771d0deeae99ca6b16f4bbeaf119bae7776a8a0bef8b7422f52ebd6498a8b5e862af4548886249386dcb44480
diff --git a/dev-util/glade/glade-3.22.2.ebuild b/dev-util/glade/glade-3.22.2.ebuild
new file mode 100644
index 000000000000..83c8db833e50
--- /dev/null
+++ b/dev-util/glade/glade-3.22.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+IUSE="debug +introspection python webkit"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.8:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# app-text/yelp-tools
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/glade/issues/333
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable webkit webkit2gtk)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}