summaryrefslogtreecommitdiff
path: root/dev-util/glslang/glslang-8.13.3559.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glslang/glslang-8.13.3559.ebuild')
-rw-r--r--dev-util/glslang/glslang-8.13.3559.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-8.13.3559.ebuild b/dev-util/glslang/glslang-8.13.3559.ebuild
new file mode 100644
index 000000000000..7ce2721cbd0d
--- /dev/null
+++ b/dev-util/glslang/glslang-8.13.3559.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="!<media-libs/shaderc-2019-r1"
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"