summaryrefslogtreecommitdiff
path: root/dev-util/gyp/gyp-99999999999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gyp/gyp-99999999999999.ebuild')
-rw-r--r--dev-util/gyp/gyp-99999999999999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-util/gyp/gyp-99999999999999.ebuild b/dev-util/gyp/gyp-99999999999999.ebuild
index da57f66635d9..bf36a597b2c0 100644
--- a/dev-util/gyp/gyp-99999999999999.ebuild
+++ b/dev-util/gyp/gyp-99999999999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_6,3_7})
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
DISTUTILS_SINGLE_IMPL="1"
DISTUTILS_USE_SETUPTOOLS="rdepend"
@@ -31,8 +31,19 @@ BDEPEND=""
DEPEND=""
RDEPEND=""
-src_test() {
- # More errors when DeprecationWarnings enabled.
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
+ sed \
+ -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
+ -e "s/conditions is ()/conditions == ()/" \
+ -i test/lib/TestCmd.py || die
+}
+
+python_test() {
+ # More errors with DeprecationWarnings enabled.
local -x PYTHONWARNINGS=""
"${PYTHON}" gyptest.py --all --verbose