summaryrefslogtreecommitdiff
path: root/dev-util/hip/files/hip-3.9.0-DisableTest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hip/files/hip-3.9.0-DisableTest.patch')
-rw-r--r--dev-util/hip/files/hip-3.9.0-DisableTest.patch87
1 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/hip/files/hip-3.9.0-DisableTest.patch b/dev-util/hip/files/hip-3.9.0-DisableTest.patch
new file mode 100644
index 000000000000..3fc787a7354e
--- /dev/null
+++ b/dev-util/hip/files/hip-3.9.0-DisableTest.patch
@@ -0,0 +1,87 @@
+--- a/CMakeLists.txt 2020-11-15 11:26:09.747793881 +0100
++++ b/CMakeLists.txt 2020-11-15 11:28:45.289793287 +0100
+@@ -676,45 +676,45 @@
+ # Target: test
+ set(HIP_ROOT_DIR ${CMAKE_CURRENT_BINARY_DIR})
+ set(HIP_SRC_PATH ${CMAKE_CURRENT_SOURCE_DIR})
+-if(HIP_PLATFORM STREQUAL "nvcc")
+- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${CMAKE_CURRENT_BINARY_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-endif()
+-execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-if(${RUN_HIT} EQUAL 0)
+- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-endif()
+-if(${RUN_HIT} EQUAL 0)
+- set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
+- include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
+-
+- # Add tests
+- include_directories(${HIP_SRC_PATH}/tests/src)
+- hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/src "directed_tests")
+-
+- # Add unit tests
+- include_directories(${HIP_SRC_PATH}/tests/unit)
+- hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/unit "unit_tests")
+-
+- # Add performance tests
+- include_directories(${HIP_SRC_PATH}/tests/performance)
+- hit_add_directory_recursive(${HIP_CTEST_CONFIG_PERFORMANCE} ${HIP_SRC_PATH}/tests/performance "performance_tests")
+-
+- # Add top-level tests to build_tests
+- add_custom_target(build_tests DEPENDS directed_tests unit_tests)
+-
+- # Add top-level tests to build performance_tests.
+- # To build performance tests, just run "make build_perf"
+- add_custom_target(build_perf DEPENDS performance_tests)
+-
+- # Add custom target: perf.
+- # To run performance tests, just run "make perf"
+- add_custom_target(perf COMMAND "${CMAKE_CTEST_COMMAND}" -C "${HIP_CTEST_CONFIG_PERFORMANCE}" -R "performance_tests/" --verbose)
+-
+- # Add custom target: check
+- add_custom_target(check COMMAND "${CMAKE_COMMAND}" --build . --target test DEPENDS build_tests)
+-else()
+- message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
+-endif()
++#if(HIP_PLATFORM STREQUAL "nvcc")
++# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${CMAKE_CURRENT_BINARY_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#endif()
++#execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#if(${RUN_HIT} EQUAL 0)
++# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#endif()
++#if(${RUN_HIT} EQUAL 0)
++# set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
++# include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
++#
++# # Add tests
++# include_directories(${HIP_SRC_PATH}/tests/src)
++# hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/src "directed_tests")
++#
++# # Add unit tests
++# include_directories(${HIP_SRC_PATH}/tests/unit)
++# hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/unit "unit_tests")
++#
++# # Add performance tests
++# include_directories(${HIP_SRC_PATH}/tests/performance)
++# hit_add_directory_recursive(${HIP_CTEST_CONFIG_PERFORMANCE} ${HIP_SRC_PATH}/tests/performance "performance_tests")
++#
++# # Add top-level tests to build_tests
++# add_custom_target(build_tests DEPENDS directed_tests unit_tests)
++#
++# # Add top-level tests to build performance_tests.
++# # To build performance tests, just run "make build_perf"
++# add_custom_target(build_perf DEPENDS performance_tests)
++#
++# # Add custom target: perf.
++# # To run performance tests, just run "make perf"
++# add_custom_target(perf COMMAND "${CMAKE_CTEST_COMMAND}" -C "${HIP_CTEST_CONFIG_PERFORMANCE}" -R "performance_tests/" --verbose)
++#
++# # Add custom target: check
++# add_custom_target(check COMMAND "${CMAKE_COMMAND}" --build . --target test DEPENDS build_tests)
++#else()
++# message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
++#endif()
+
+ #############################
+ # Code analysis