summaryrefslogtreecommitdiff
path: root/dev-util/hipcc/hipcc-5.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hipcc/hipcc-5.7.1.ebuild')
-rw-r--r--dev-util/hipcc/hipcc-5.7.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-util/hipcc/hipcc-5.7.1.ebuild b/dev-util/hipcc/hipcc-5.7.1.ebuild
new file mode 100644
index 000000000000..062d629e1a4c
--- /dev/null
+++ b/dev-util/hipcc/hipcc-5.7.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Radeon Open Compute hipcc"
+HOMEPAGE="https://github.com/ROCm-Developer-Tools/hipcc"
+
+KEYWORDS="~amd64"
+SRC_URI="https://github.com/ROCm-Developer-Tools/hipcc/archive/refs/tags/rocm-${PV}.tar.gz -> hipcc-${PV}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/HIPCC-rocm-${PV}