summaryrefslogtreecommitdiff
path: root/dev-util/howdoi/howdoi-2.0.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/howdoi/howdoi-2.0.20.ebuild')
-rw-r--r--dev-util/howdoi/howdoi-2.0.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/howdoi/howdoi-2.0.20.ebuild b/dev-util/howdoi/howdoi-2.0.20.ebuild
new file mode 100644
index 000000000000..bece62a0a155
--- /dev/null
+++ b/dev-util/howdoi/howdoi-2.0.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A code search tool"
+HOMEPAGE="https://pypi.org/project/howdoi/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# bug 818580
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cachelib[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/keep[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyquery-1.4.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+"