summaryrefslogtreecommitdiff
path: root/dev-util/kube-linter/kube-linter-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kube-linter/kube-linter-0.3.0.ebuild')
-rw-r--r--dev-util/kube-linter/kube-linter-0.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/kube-linter/kube-linter-0.3.0.ebuild b/dev-util/kube-linter/kube-linter-0.3.0.ebuild
new file mode 100644
index 000000000000..45b858d5153a
--- /dev/null
+++ b/dev-util/kube-linter/kube-linter-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="kubernetes yaml and helm chart static analysis tool"
+HOMEPAGE="https://kubelinter.io"
+SRC_URI="https://github.com/stackrox/kube-linter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake TAG=${PV} build
+}
+
+src_install() {
+ dobin .gobin/kube-linter
+ dodoc -r config.yaml.example docs/*
+}
+
+src_test() {
+ emake TAG=${PV} test
+}