summaryrefslogtreecommitdiff
path: root/dev-util/libabigail/libabigail-2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/libabigail/libabigail-2.0.ebuild')
-rw-r--r--dev-util/libabigail/libabigail-2.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/libabigail/libabigail-2.0.ebuild b/dev-util/libabigail/libabigail-2.0.ebuild
index 61ac2094d397..8c7bf65df427 100644
--- a/dev-util/libabigail/libabigail-2.0.ebuild
+++ b/dev-util/libabigail/libabigail-2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-any-r1 out-of-source
@@ -19,9 +19,11 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/elfutils
- dev-libs/libxml2:2"
+ dev-libs/libxml2:2
+ elibc_musl? ( sys-libs/fts-standalone )"
DEPEND="${RDEPEND}"
BDEPEND="
+ virtual/pkgconfig
doc? (
app-doc/doxygen
dev-python/sphinx
@@ -29,6 +31,8 @@ BDEPEND="
)
test? ( ${PYTHON_DEPS} )"
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
src_prepare() {
default
# need to run our autotools, due to ltmain.sh including Redhat calls: