summaryrefslogtreecommitdiff
path: root/dev-util/libtree/libtree-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/libtree/libtree-3.0.2.ebuild')
-rw-r--r--dev-util/libtree/libtree-3.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/libtree/libtree-3.0.2.ebuild b/dev-util/libtree/libtree-3.0.2.ebuild
new file mode 100644
index 000000000000..6ed6a5aae88a
--- /dev/null
+++ b/dev-util/libtree/libtree-3.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}