summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild')
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
new file mode 100644
index 000000000000..97c50c2b4af0
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+DEPEND="${RDEPEND}"