summaryrefslogtreecommitdiff
path: root/dev-util/maturin/maturin-0.11.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/maturin/maturin-0.11.5.ebuild')
-rw-r--r--dev-util/maturin/maturin-0.11.5.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-0.11.5.ebuild b/dev-util/maturin/maturin-0.11.5.ebuild
index e4c63d8660ab..896159452b6d 100644
--- a/dev-util/maturin/maturin-0.11.5.ebuild
+++ b/dev-util/maturin/maturin-0.11.5.ebuild
@@ -243,7 +243,7 @@ CRATES_TEST="
scopeguard-1.1.0
smallvec-1.7.0"
PYTHON_COMPAT=( python3_{8..10} )
-inherit cargo python-any-r1
+inherit cargo flag-o-matic python-any-r1
DESCRIPTION="Build and publish crates with pyo3, rust-cpython and cffi bindings"
HOMEPAGE="https://github.com/pyo3/maturin"
@@ -254,7 +254,7 @@ SRC_URI="
LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD ISC MIT MPL-2.0 openssl"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="test"
PROPERTIES="test_network"
RESTRICT="test" # uses venv+pip
@@ -278,6 +278,12 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_configure() {
+ filter-flags '-flto*' # undefined references with ring crate
+
+ cargo_src_configure
+}
+
src_test() {
cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock
}