summaryrefslogtreecommitdiff
path: root/dev-util/maturin/maturin-0.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/maturin/maturin-0.13.1.ebuild')
-rw-r--r--dev-util/maturin/maturin-0.13.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-0.13.1.ebuild b/dev-util/maturin/maturin-0.13.1.ebuild
index 1d9dbacce256..d63cc20f6be5 100644
--- a/dev-util/maturin/maturin-0.13.1.ebuild
+++ b/dev-util/maturin/maturin-0.13.1.ebuild
@@ -386,13 +386,13 @@ src_prepare() {
# ensure rustls is disabled on arches where ring crate is problematic,
# add as needed and keep in sync with src_configure below (bug #859577)
- if use ppc || use ppc64 || use s390; then
+ if use ppc || use ppc64 || use riscv || use s390; then
sed -i '/^if platform.machine/s/^if/if True or/' setup.py || die
fi
}
src_configure() {
- if use ppc || use ppc64 || use s390; then
+ if use ppc || use ppc64 || use riscv || use s390; then
local myfeatures=( upload log human-panic ) # sync with setup.py
cargo_src_configure --no-default-features
fi