summaryrefslogtreecommitdiff
path: root/dev-util/maturin/maturin-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/maturin/maturin-1.6.0.ebuild')
-rw-r--r--dev-util/maturin/maturin-1.6.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-util/maturin/maturin-1.6.0.ebuild b/dev-util/maturin/maturin-1.6.0.ebuild
index da76be521596..0db2445f7122 100644
--- a/dev-util/maturin/maturin-1.6.0.ebuild
+++ b/dev-util/maturin/maturin-1.6.0.ebuild
@@ -532,7 +532,6 @@ python_compile_all() {
}
python_test() {
- local -x COLUMNS=100 # match clap_builder crate default
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
@@ -541,6 +540,8 @@ python_test() {
local -x PYO3_USE_ABI3_FORWARD_COMPATIBILITY=1
local skip=(
+ # picky cli output test that easily benignly fail (bug #937992)
+ --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy