summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild
index 15f76259b1af..f2723d866456 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-11.0.1.ebuild
@@ -65,11 +65,16 @@ src_configure() {
# (primarily done for 23.0 profiles' -z, not full coverage)
filter-flags '-Wl,-z,*'
- # -mavx with mingw-gcc has a history of obscure issues and
- # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
- # crashes with -march=skylake >=wine-8.10, similar issues with
- # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- tc-is-gcc && append-flags -mno-avx
+ if tc-is-gcc; then
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
+ # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
+ append-flags -fomit-frame-pointer
+ fi
strip-unsupported-flags