summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-toolchain/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-toolchain/files')
-rw-r--r--dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch22
-rw-r--r--dev-util/mingw64-toolchain/files/mingw64-runtime-10.0.0-tmp-files-clash.patch10
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch b/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch
new file mode 100644
index 000000000000..1de712de48bc
--- /dev/null
+++ b/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch
@@ -0,0 +1,22 @@
+https://gcc.gnu.org/PR95648
+--- a/gcc/config/gcc-plugin.m4
++++ b/gcc/config/gcc-plugin.m4
+@@ -47,3 +47,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
+--- a/gcc/gcc/configure
++++ b/gcc/gcc/configure
+@@ -32069,3 +32069,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
+--- a/gcc/libcc1/configure
++++ b/gcc/libcc1/configure
+@@ -15017,3 +15017,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
diff --git a/dev-util/mingw64-toolchain/files/mingw64-runtime-10.0.0-tmp-files-clash.patch b/dev-util/mingw64-toolchain/files/mingw64-runtime-10.0.0-tmp-files-clash.patch
new file mode 100644
index 000000000000..38c4abf91e77
--- /dev/null
+++ b/dev-util/mingw64-toolchain/files/mingw64-runtime-10.0.0-tmp-files-clash.patch
@@ -0,0 +1,10 @@
+Fix clash when enabling lib32 and lib64 at same time, backport from:
+https://sourceforge.net/p/mingw-w64/mingw-w64/ci/953bcd32ae470c4647e94de8548dda5a8f07d82d/
+(except directly to Makefile.in to avoid autoreconf over this)
+--- a/mingw64/mingw-w64-crt/Makefile.in
++++ b/mingw64/mingw-w64-crt/Makefile.in
+@@ -153,3 +153,3 @@
+ host_triplet = @host@
+-@DLLTOOL_HAS_TEMP_PREFIX_TRUE@am__append_1 = --temp-prefix $$(basename $@ .a)
++@DLLTOOL_HAS_TEMP_PREFIX_TRUE@am__append_1 = --temp-prefix $(basename $@)
+ @DELAY_IMPORT_LIBS_TRUE@am__append_2 = --output-delaylib $@.delayimp.a