summaryrefslogtreecommitdiff
path: root/dev-util/patchutils/patchutils-0.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchutils/patchutils-0.3.4.ebuild')
-rw-r--r--dev-util/patchutils/patchutils-0.3.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/patchutils/patchutils-0.3.4.ebuild b/dev-util/patchutils/patchutils-0.3.4.ebuild
new file mode 100644
index 000000000000..cc9698ac817a
--- /dev/null
+++ b/dev-util/patchutils/patchutils-0.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of tools that operate on patch files"
+HOMEPAGE="http://cyberelk.net/tim/patchutils/"
+SRC_URI="http://cyberelk.net/tim/data/patchutils/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+# testsuite makes use of gendiff(1) that comes from rpm, thus if the user wants
+# to run tests, it should install that package as well.
+DEPEND="test? ( app-arch/rpm )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.3-format-security.patch"
+)
+
+src_test() {
+ # See bug 605952.
+ make check || die
+}