summaryrefslogtreecommitdiff
path: root/dev-util/poke/poke-2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/poke/poke-2.4-r1.ebuild')
-rw-r--r--dev-util/poke/poke-2.4-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/poke/poke-2.4-r1.ebuild b/dev-util/poke/poke-2.4-r1.ebuild
index 4f71cf92ec9f..b64df1c180ef 100644
--- a/dev-util/poke/poke-2.4-r1.ebuild
+++ b/dev-util/poke/poke-2.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit elisp-common flag-o-matic
+inherit elisp-common flag-o-matic toolchain-funcs
DESCRIPTION="Extensible editor for structured binary data"
HOMEPAGE="https://www.jemarch.net/poke"
@@ -47,6 +47,7 @@ DEPEND="
BDEPEND="
${REGEN_BDEPEND}
virtual/pkgconfig
+ pvm-profiling? ( sys-devel/gcc )
emacs? ( >=app-editors/emacs-23.1:* )
test? (
dev-util/dejagnu
@@ -56,6 +57,12 @@ BDEPEND="
SITEFILE="50${PN}-gentoo.el"
+pkg_pretend() {
+ if use pvm-profiling && ! tc-is-gcc; then
+ die "USE=pvm-profiling requires GCC"
+ fi
+}
+
pkg_setup() {
use emacs && elisp-check-emacs-version
}