summaryrefslogtreecommitdiff
path: root/dev-util/promu/promu-0.1.0_p20180227.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/promu/promu-0.1.0_p20180227.ebuild')
-rw-r--r--dev-util/promu/promu-0.1.0_p20180227.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/promu/promu-0.1.0_p20180227.ebuild b/dev-util/promu/promu-0.1.0_p20180227.ebuild
new file mode 100644
index 000000000000..94c084e7161a
--- /dev/null
+++ b/dev-util/promu/promu-0.1.0_p20180227.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="5a3cc08574c63bb853a21c570d719a0fb548dae0"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN}/VERSION)
+ -X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT:0:7}
+ -extldflags \"-static\""
+ GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}