summaryrefslogtreecommitdiff
path: root/dev-util/pwndbg/pwndbg-99999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pwndbg/pwndbg-99999999.ebuild')
-rw-r--r--dev-util/pwndbg/pwndbg-99999999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-util/pwndbg/pwndbg-99999999.ebuild b/dev-util/pwndbg/pwndbg-99999999.ebuild
index bcd220f3d9af..bd3b1a48231a 100644
--- a/dev-util/pwndbg/pwndbg-99999999.ebuild
+++ b/dev-util/pwndbg/pwndbg-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,15 +32,16 @@ RDEPEND="
${PYTHON_DEPS}
sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
- dev-libs/capstone[python,${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pycparser[${PYTHON_USEDEP}]
- dev-python/pyelftools[${PYTHON_USEDEP}]
- dev-python/python-ptrace[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-util/ROPgadget[${PYTHON_USEDEP}]
- dev-util/unicorn[python,${PYTHON_USEDEP}]
+ >=dev-libs/capstone-4.0.2[python,${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ >=dev-python/pycparser-2.21[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.29[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3.0[${PYTHON_USEDEP}]
+ >=dev-util/pwntools-4.9.0[${PYTHON_USEDEP}]
+ >=dev-util/ROPgadget-7.2[${PYTHON_USEDEP}]
+ >=dev-util/unicorn-2.0.1[python,${PYTHON_USEDEP}]
')"
src_prepare() {