summaryrefslogtreecommitdiff
path: root/dev-util/re2c/re2c-0.13.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/re2c/re2c-0.13.5-r1.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.13.5-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.13.5-r1.ebuild b/dev-util/re2c/re2c-0.13.5-r1.ebuild
new file mode 100644
index 000000000000..d04be68e9eb1
--- /dev/null
+++ b/dev-util/re2c/re2c-0.13.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+MY_PV="${PV/_/.}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dobin re2c
+ doman re2c.1
+ dodoc README CHANGELOG doc/*
+ docinto examples
+ dodoc examples/*.c examples/*.re
+}