summaryrefslogtreecommitdiff
path: root/dev-util/regexxer/regexxer-0.10-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/regexxer/regexxer-0.10-r2.ebuild')
-rw-r--r--dev-util/regexxer/regexxer-0.10-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/regexxer/regexxer-0.10-r2.ebuild b/dev-util/regexxer/regexxer-0.10-r2.ebuild
new file mode 100644
index 000000000000..6d9cd50b654f
--- /dev/null
+++ b/dev-util/regexxer/regexxer-0.10-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools gnome2
+
+DESCRIPTION="An interactive tool for performing search and replace operations"
+HOMEPAGE="http://regexxer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib-2.32.patch
+ "${FILESDIR}"/${P}-sandbox.patch
+ "${FILESDIR}"/${P}-exception-prefdialog.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}