summaryrefslogtreecommitdiff
path: root/dev-util/rgbds/rgbds-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rgbds/rgbds-9999.ebuild')
-rw-r--r--dev-util/rgbds/rgbds-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/rgbds/rgbds-9999.ebuild b/dev-util/rgbds/rgbds-9999.ebuild
index 51e115fe3583..15f4299a0ec4 100644
--- a/dev-util/rgbds/rgbds-9999.ebuild
+++ b/dev-util/rgbds/rgbds-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/gbdev/${PN}.git"
else
SRC_URI="https://github.com/gbdev/${PN}/archive/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
@@ -20,7 +20,8 @@ SLOT="0"
DEPEND="media-libs/libpng"
RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
+BDEPEND="app-alternatives/yacc[bison]
+ virtual/pkgconfig"
src_compile() {
append-flags -DNDEBUG