summaryrefslogtreecommitdiff
path: root/dev-util/rosdep/rosdep-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rosdep/rosdep-9999.ebuild')
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index aa7a8d86538f..861de0006ff1 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,14 +39,18 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-python/nose[${PYTHON_USEDEP}]
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flake8[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/tests.patch" )
python_test() {
- nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping tests due to network sandbox"
+ else
+ env -u ROS_DISTRO nosetests --with-xunit test || die
+ fi
}
pkg_postrm() {