summaryrefslogtreecommitdiff
path: root/dev-util/scala-ide/scala-ide-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scala-ide/scala-ide-4.3.0.ebuild')
-rw-r--r--dev-util/scala-ide/scala-ide-4.3.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-util/scala-ide/scala-ide-4.3.0.ebuild b/dev-util/scala-ide/scala-ide-4.3.0.ebuild
deleted file mode 100644
index f562273c4257..000000000000
--- a/dev-util/scala-ide/scala-ide-4.3.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-# scala-ide -> scalaide
-S_PACK="${PN/-/}-pack"
-
-# scala-ide -> scala-SDK-${PV}
-S_SDK="${PN%-*}-SDK-${PV}"
-
-SRC_URI_AMD64="http://downloads.typesafe.com/${S_PACK}/${PV}-vfinal-luna-211-20151201/${S_SDK}-vfinal-2.11-linux.gtk.x86_64.tar.gz"
-SRC_URI_X86="http://downloads.typesafe.com/${S_PACK}/${PV}-vfinal-luna-211-20151201/${S_SDK}-vfinal-2.11-linux.gtk.x86.tar.gz"
-
-DESCRIPTION="The Scala IDE"
-HOMEPAGE="http://www.scala-ide.org"
-KEYWORDS="amd64 x86"
-SRC_URI="
- amd64? ( ${SRC_URI_AMD64} )
- x86? ( ${SRC_URI_X86} )
-"
-
-SLOT="0"
-LICENSE="BSD"
-
-RDEPEND=">=virtual/jdk-1.6
- || (
- dev-lang/scala
- dev-lang/scala-bin
- )"
-
-MY_D="/opt"
-
-src_unpack() {
- default
- unpack ${A}
- mv "${WORKDIR}"/eclipse "${WORKDIR}"/"${P}" || die
-}
-
-src_prepare() {
- mv "${WORKDIR}"/"${P}"/eclipse "${WORKDIR}"/"${P}"/"${PN}" || die
-}
-
-src_install() {
- cd "${D}" || die
- dodir "${MY_D}"
- insinto "${MY_D}"
- doins -r "${WORKDIR}"/"${P}"
- insopts -m 0755
- insinto "${MY_D}"/"${P}"
- doins "${WORKDIR}"/"${P}"/"${PN}"
- dosym ${MY_D}/${P}/${PN} /usr/bin/${PN}
-}