summaryrefslogtreecommitdiff
path: root/dev-util/scanmem/scanmem-0.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scanmem/scanmem-0.17.ebuild')
-rw-r--r--dev-util/scanmem/scanmem-0.17.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-util/scanmem/scanmem-0.17.ebuild b/dev-util/scanmem/scanmem-0.17.ebuild
index 0f73625fc11a..35fff207b409 100644
--- a/dev-util/scanmem/scanmem-0.17.ebuild
+++ b/dev-util/scanmem/scanmem-0.17.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-single-r1
DESCRIPTION="Locate and modify variables in executing processes"
@@ -16,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
IUSE="gui static-libs"
-DEPEND="sys-libs/readline:0="
+DEPEND="sys-libs/readline:="
RDEPEND="${DEPEND}
gui? (
${PYTHON_DEPS}
@@ -26,6 +25,10 @@ RDEPEND="${DEPEND}
REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-tests.patch
+)
+
pkg_setup() {
use gui && python-single-r1_pkg_setup
}
@@ -44,6 +47,7 @@ src_configure() {
$(use_enable gui)
$(use_enable static-libs static)
)
+
econf "${myeconfargs[@]}"
}