summaryrefslogtreecommitdiff
path: root/dev-util/splint/splint-3.1.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/splint/splint-3.1.2-r2.ebuild')
-rw-r--r--dev-util/splint/splint-3.1.2-r2.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/splint/splint-3.1.2-r2.ebuild b/dev-util/splint/splint-3.1.2-r2.ebuild
index b47c46e8e141..1975543f7f9d 100644
--- a/dev-util/splint/splint-3.1.2-r2.ebuild
+++ b/dev-util/splint/splint-3.1.2-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
HOMEPAGE="http://lclint.cs.virginia.edu/"
@@ -12,12 +13,14 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~x64-macos"
-DEPEND="
- sys-devel/flex
-"
+DEPEND="sys-devel/flex"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.2-musl.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.1.2-musl.patch
+ default
# verbose compiler calls
sed -i -e '/Compiling/d' src/Makefile.am || die