summaryrefslogtreecommitdiff
path: root/dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild')
-rw-r--r--dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild b/dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..7a237d62e478
--- /dev/null
+++ b/dev-util/stressapptest/stressapptest-1.0.9-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Stressful Application Test"
+HOMEPAGE="https://github.com/stressapptest/stressapptest"
+SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libaio"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Matches the configure & sat.cc logic
+ use debug || append-cppflags -DNDEBUG -DCHECKOPTS
+ econf --disable-default-optimizations
+}