summaryrefslogtreecommitdiff
path: root/dev-util/tmake/tmake-2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/tmake/tmake-2.12.ebuild')
-rw-r--r--dev-util/tmake/tmake-2.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/tmake/tmake-2.12.ebuild b/dev-util/tmake/tmake-2.12.ebuild
new file mode 100644
index 000000000000..751d77e77003
--- /dev/null
+++ b/dev-util/tmake/tmake-2.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+DESCRIPTION="A Cross platform Makefile tool"
+SRC_URI="mirror://sourceforge/tmake/${P}.tar.bz2"
+HOMEPAGE="http://tmake.sourceforge.net"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5"
+
+src_install () {
+ dobin bin/tmake bin/progen
+ dodir /usr/lib/tmake
+ cp -pPRf "${S}"/lib/* "${ED}"/usr/lib/tmake
+ dodoc README
+ dohtml -r doc/*
+ echo "TMAKEPATH=\"${EPREFIX}/usr/lib/tmake/linux-g++\"" > "${T}"/51tmake
+ doenvd "${T}"/51tmake
+}