summaryrefslogtreecommitdiff
path: root/dev-util/trinity/trinity-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/trinity/trinity-9999.ebuild')
-rw-r--r--dev-util/trinity/trinity-9999.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-util/trinity/trinity-9999.ebuild b/dev-util/trinity/trinity-9999.ebuild
deleted file mode 100644
index 2e263c788cee..000000000000
--- a/dev-util/trinity/trinity-9999.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs git-r3
-
-EGIT_REPO_URI="https://github.com/kernelslacker/trinity.git"
-
-DESCRIPTION="A Linux system call fuzz tester"
-HOMEPAGE="http://codemonkey.org.uk/projects/trinity/ https://github.com/kernelslacker/trinity/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples"
-
-DEPEND="sys-kernel/linux-headers"
-
-src_prepare() {
- sed -e 's/-g -O2//' \
- -e 's/-D_FORTIFY_SOURCE=2//' \
- -e '/-o $@/s/$(LDFLAGS) //' \
- -i Makefile || die
-
- tc-export CC
- default
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- dobin ${PN}
- dodoc Documentation/* README
-
- if use examples ; then
- exeinto /usr/share/doc/${PF}/scripts
- doexe scripts/*
- docompress -x /usr/share/doc/${PF}/scripts
- fi
-}