summaryrefslogtreecommitdiff
path: root/dev-util/vint/vint-0.3.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vint/vint-0.3.19.ebuild')
-rw-r--r--dev-util/vint/vint-0.3.19.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-util/vint/vint-0.3.19.ebuild b/dev-util/vint/vint-0.3.19.ebuild
deleted file mode 100644
index 1e5cc17ad27c..000000000000
--- a/dev-util/vint/vint-0.3.19.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Lint tool for Vim script language"
-HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
-SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- virtual/python-typing[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.3.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.5.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
- )
-"
-
-python_test() {
- py.test -v || die "Test suite failed with ${EPYTHON}"
-}