summaryrefslogtreecommitdiff
path: root/dev-util/woke/woke-0.18.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/woke/woke-0.18.2.ebuild')
-rw-r--r--dev-util/woke/woke-0.18.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/woke/woke-0.18.2.ebuild b/dev-util/woke/woke-0.18.2.ebuild
new file mode 100644
index 000000000000..8b05194f95ee
--- /dev/null
+++ b/dev-util/woke/woke-0.18.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="check source code for non-inclusive language"
+HOMEPAGE="https://getwoke.tech/"
+SRC_URI="https://github.com/get-woke/woke/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build .
+}
+
+src_install() {
+ dobin woke
+ dodoc README.md example.yaml
+}