summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin68259 -> 68262 bytes
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-241.ebuild120
-rw-r--r--dev-util/gef/Manifest4
-rw-r--r--dev-util/gef/gef-2023.06.ebuild82
-rw-r--r--dev-util/gef/gef-9999.ebuild2
6 files changed, 208 insertions, 2 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 76e3366cea1d..e279779b2069 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index c81df886a263..a424738b98f0 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-238.tar.gz 3287285 BLAKE2B d745c0b279ce6e29cbe9c6655c48d2fb4c8d230c5d4931048be83b4d97f6b45bff5424409b559988c2efba2dcbb80778c97e3f726174ae154c479ec24b557c34 SHA512 8600a3a29f7d4a80f0a0b37e6277e46e377c6f056cf111356f80723f0e4a309e9bae087643019fe1c46f99430b35389083e1156911fa8d3375993b550342b25f
DIST diffoscope-240.tar.gz 3167743 BLAKE2B e6eb9f7499ea7d82d9a98de175f61c044051c987061d740599f490361099ecc568d8e557f9473404ca1002c4b91939b768dd7577ba45705e9880a3e17e3729ac SHA512 3d31e19762e9f5adfe12c16fc52bc0156f3036541de01cbc260c07ebbcab54eaa23b4b9f9c2afc3c791137f7e6cc375de06528f64e0771cbebd9e23f310a6e2b
+DIST diffoscope-241.tar.gz 3167718 BLAKE2B eb69f65a63e764db886c6057a19746a5ae7f4f5cd760c8a568412084dbf03da368a584d7d5b1f637e1d2e39b6fc430d077be526fd3199d5583e3f9026f897490 SHA512 82526a4bf3885b58fef74143bc75193fc9af2692def097835cc3c820e5055b22544872c0e1a8f13fb1434172cf1cc2b3664b2d2776590195b0580c5c0b3f4d57
EBUILD diffoscope-238.ebuild 3575 BLAKE2B 73da8bb1fefaf3b4386b7f85ca3579cdd19ce296eb67603eb5106b85be0d5eaa729c6e63c4b2a962787dca210f934d99383c10c2e50a6be74bf66851799d65b3 SHA512 6e04cd441cb9021b094061a7e217c27bf005d954dac711438e52411df676468847edda78800b63c32261b0dc45c119c36b2eac4864b57639cb029eef89447221
EBUILD diffoscope-240.ebuild 3577 BLAKE2B 24f34c7c52e646308106a841f1f3b5ef0795386d1bd514f93ea40ed03b752d328a4884219f88818486853f9f3f52433d32cb4d8f8744842ac01018ddc28308c8 SHA512 cece2cffa44e55eb15d025f44c624c1439a509adccee82e0754b43b4dc3b61e9e580a7c0b556b899f032a76c1df4083e76dccaa82474cb1518f31e2d6a6acf32
+EBUILD diffoscope-241.ebuild 3577 BLAKE2B 24f34c7c52e646308106a841f1f3b5ef0795386d1bd514f93ea40ed03b752d328a4884219f88818486853f9f3f52433d32cb4d8f8744842ac01018ddc28308c8 SHA512 cece2cffa44e55eb15d025f44c624c1439a509adccee82e0754b43b4dc3b61e9e580a7c0b556b899f032a76c1df4083e76dccaa82474cb1518f31e2d6a6acf32
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-241.ebuild b/dev-util/diffoscope/diffoscope-241.ebuild
new file mode 100644
index 000000000000..d598e5340b57
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-241.ebuild
@@ -0,0 +1,120 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1 pypi
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/pypdf[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence of filemagic's magic.py breaks imports
+# of dev-python/python-magic: bug #716482
+RDEPEND+=" !dev-python/filemagic"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ tests/comparators/test_macho.py::test_llvm_diff
+ tests/comparators/test_elf.py::test_libmix_differences
+)
+
+distutils_enable_tests pytest
diff --git a/dev-util/gef/Manifest b/dev-util/gef/Manifest
index 88cbdd3587ac..bb4fb0e27926 100644
--- a/dev-util/gef/Manifest
+++ b/dev-util/gef/Manifest
@@ -1,4 +1,6 @@
DIST gef-2022.06.tar.gz 217503 BLAKE2B b7038e0519f216669c38bdda7e12375fb1c9e5278c8b617df73932a750ee6552531929eebcac22321607f51592834ece70c850ce0ba4629bc383731bc8803bb3 SHA512 585bad8655a5208d060b1ccf455ab87527e47949fce1df188a5ac970ccd1bbfbdd87151f7a940edcfb879dd0ea846b5c4a8650fed856cd5dcaec0ddd3581f100
+DIST gef-2023.06.tar.gz 187126 BLAKE2B e44606249d42760caf4e47f1b2f5e4592255fd8b81b28cab313352d10dcbc47a79a0130e102cc2618fe88dc47a5589ed6bee3e7d80878cc66f5e9abd775c103e SHA512 5362234ae6b753abe719280640148978cd25f535249a1ad9311ebd66f99138d59d5b9f07e9e93ebe00aab4702c73229c2f3d92e2d70fb5daf3f30a49e4d3b8ff
EBUILD gef-2022.06-r1.ebuild 1603 BLAKE2B caea975d2a7e9d40aaa5dc7f4bedd33bdf36fb41706ffb1ed3a67065577e332b10b63bb194d124a0f3446b5902ff332b243425359605b87d45e4b0663080536d SHA512 bf968affb09420dbc5d5ec6fb17a8a3d6c7c217673c3c43e2a061faac3e0e561ff3966cae9f6524064a8d0401530747cd0b794e5e7089574f39cbab054f7595f
-EBUILD gef-9999.ebuild 1581 BLAKE2B 4ac30faab6ee9278bd922666e7588c78dfc7279a5937e5b9b70a7ed90fc63a0d1b9e53812333bda67466fe7b485c277876b0667d1bd82a2feb8931b5791f2fe0 SHA512 02d1b0b9fb7dedbef6f2f7ca00f569952b1274f5ff08333bf784e6bc962c516c73e6d059aa8dc8aaf77b2b385dd4f2678996b492fdd5ababcf1fa4d7445b024d
+EBUILD gef-2023.06.ebuild 1605 BLAKE2B ccc0b89381ffd49e6f6e55c6c3569bff510f1748e0ef0c49201721f2f3e4acc8b125dfeca78b8966861d84a318bc4f4203d3f8a7b0577ee84f1163e6d1ccb0ad SHA512 5d1d6e1cbb81469814fcb12276c8c95fc0e1379f1f32075318e26220ed477d30bb42b39321d2fa96139c23ab8c382070d66758d215944024d1b42ad8ed3e770e
+EBUILD gef-9999.ebuild 1605 BLAKE2B ccc0b89381ffd49e6f6e55c6c3569bff510f1748e0ef0c49201721f2f3e4acc8b125dfeca78b8966861d84a318bc4f4203d3f8a7b0577ee84f1163e6d1ccb0ad SHA512 5d1d6e1cbb81469814fcb12276c8c95fc0e1379f1f32075318e26220ed477d30bb42b39321d2fa96139c23ab8c382070d66758d215944024d1b42ad8ed3e770e
MISC metadata.xml 995 BLAKE2B f4c30ac2ea932c90b74800c44389169199cdc189e69584a3873c91b36086eb30b5d463a12a5b08cc45196aa57e939d00806e3d1e96fbb647c997ab891a312ea0 SHA512 b4e09578a7f5656688dced42d1f924ba928b59abcb8345fe143be11ae30b553cda26663c6771a99e44ffc9f72c187b871ee2d1c096bf49d37b1e0fd460653ad4
diff --git a/dev-util/gef/gef-2023.06.ebuild b/dev-util/gef/gef-2023.06.ebuild
new file mode 100644
index 000000000000..d6b6691121d0
--- /dev/null
+++ b/dev-util/gef/gef-2023.06.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-material
+"
+
+inherit python-single-r1 docs wrapper
+
+DESCRIPTION="A GDB Enhanced Features for exploit devs & reversers"
+HOMEPAGE="https://github.com/hugsy/gef"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hugsy/gef"
+else
+ SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# Seem to hang right now?
+RESTRICT="!test? ( test ) test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ropper[${PYTHON_SINGLE_USEDEP}]
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-util/unicorn[python,${PYTHON_USEDEP}]
+ ')"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e '/pylint/d' tests/requirements.txt || die
+}
+
+src_compile() {
+ # Tries to compile tests
+ :
+
+ docs_compile
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r *.py
+
+ python_optimize "${ED}/usr/share/${PN}"
+
+ make_wrapper "gdb-gef" \
+ "gdb -x \"/usr/share/${PN}/gef.py\"" || die
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-gef <program>\n"
+}
diff --git a/dev-util/gef/gef-9999.ebuild b/dev-util/gef/gef-9999.ebuild
index cd097e27cf2d..d6b6691121d0 100644
--- a/dev-util/gef/gef-9999.ebuild
+++ b/dev-util/gef/gef-9999.ebuild
@@ -20,7 +20,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/hugsy/gef"
else
SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"