summaryrefslogtreecommitdiff
path: root/dev-vcs/git-lfs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/Manifest4
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.4.2.ebuild44
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild47
-rw-r--r--dev-vcs/git-lfs/metadata.xml11
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
new file mode 100644
index 000000000000..f486e93c7ac1
--- /dev/null
+++ b/dev-vcs/git-lfs/Manifest
@@ -0,0 +1,4 @@
+DIST git-lfs-2.4.2.tar.gz 791443 BLAKE2B 6c613ad5b644f609b36a6a5c569c3512713d0f5fc925be759b20a01ca0e57573246557e887e086b52c5703db9db4d8a49fe91761efec48410738724256cac9e9 SHA512 c89a15c36b9d52091eb6e89f8e1db23b03f35333794467432ee49728ba83fc5d25d238f5df49bf736a4a3079778d70a527db01c2299ecd96a7b5f70059616967
+EBUILD git-lfs-2.4.2.ebuild 969 BLAKE2B 4e7349b225cdae63ab30312a30a8c58deec1d89cc238dfecf505986ce1f798607b3fb63dd1b5ad22dc74bc8428d51e0532580cdf6b37628afa730e7b104445f3 SHA512 73e9130ecf33dc94f5067353d183306643167897f5ff450185d057ca8b7089cec2bd173b08e97042df2483b500136654d1f62275d7242b25857bd4ad7f5f2584
+EBUILD git-lfs-9999.ebuild 1153 BLAKE2B 6c67ac1d61b9be2021bea634c5a2a7d4f50b3044d1ddf1ebdcdb21580bc723d5fe8890b098dcb12f5719d415be4fb187ca51414ab2efdbeb54bee72828b2d276 SHA512 317104891a95804da6b28e29b0930aad843597d1d9996518a18e7c71290753ac86405364426693adefc2f103a7b393a97e7d79589dfa05e58a8ed5d6a32a61b1
+MISC metadata.xml 331 BLAKE2B ec49bde06277ccbdacd3b6c50e0e32c5b14464ad015e1a7a57446e905d0ed9b3b0b71650a455a3b77c5e0ac2530874f37327b1fef3c924577b08c1e1c815c201 SHA512 51f68466f5396fe0326aab5f3a5fa70761647d722d02339fd6072d21976dfd27fdafa1ee44680be98dd0c1b80b29801eb7ed1508aa850104bed564c5f1a38011
diff --git a/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild b/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild
new file mode 100644
index 000000000000..a3aad04e586d
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
new file mode 100644
index 000000000000..7a32ca36cc92
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+# since version 2.0.2 git-lfs uses time.Until that was introduced in golang >=1.8
+# https://github.com/golang/go/commit/67ea710792eabdae1182e2bf4845f512136cccce
+DEPEND=">=dev-lang/go-1.8.1:=
+ doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}
diff --git a/dev-vcs/git-lfs/metadata.xml b/dev-vcs/git-lfs/metadata.xml
new file mode 100644
index 000000000000..657593267204
--- /dev/null
+++ b/dev-vcs/git-lfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mudler@gentoo.org</email>
+ <name>Ettore Di Giacinto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">git-lfs/git-lfs</remote-id>
+ </upstream>
+</pkgmetadata>