summaryrefslogtreecommitdiff
path: root/dev-vcs/git-mantle/git-mantle-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-mantle/git-mantle-0.6.ebuild')
-rw-r--r--dev-vcs/git-mantle/git-mantle-0.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/git-mantle/git-mantle-0.6.ebuild b/dev-vcs/git-mantle/git-mantle-0.6.ebuild
new file mode 100644
index 000000000000..08268e572163
--- /dev/null
+++ b/dev-vcs/git-mantle/git-mantle-0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generate an overview of changes on a branch"
+HOMEPAGE="https://github.com/roman-neuhauser/git-mantle"
+
+SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? ( dev-util/cram )"
+RDEPEND="
+ dev-vcs/git
+ app-shells/zsh
+"
+
+src_install() {
+ # Don't install in /usr/local
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}