summaryrefslogtreecommitdiff
path: root/dev-vcs/git-tools/git-tools-2020.09.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-tools/git-tools-2020.09.ebuild')
-rw-r--r--dev-vcs/git-tools/git-tools-2020.09.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/git-tools/git-tools-2020.09.ebuild b/dev-vcs/git-tools/git-tools-2020.09.ebuild
new file mode 100644
index 000000000000..60d9f62d7823
--- /dev/null
+++ b/dev-vcs/git-tools/git-tools-2020.09.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-r1
+
+DESCRIPTION="Assorted git-related scripts"
+HOMEPAGE="https://github.com/MestreLion/git-tools"
+SRC_URI="https://github.com/MestreLion/git-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-2.5
+ >=app-shells/bash-4.0"
+
+src_install() {
+ dobin git-branches-rename git-clone-subset git-find-uncommitted-repos
+ dobin git-rebase-theirs git-strip-merge
+ python_foreach_impl python_doscript git-restore-mtime
+ doman man1/*.1
+ einstalldocs
+}