summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-2.34.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-2.34.1.ebuild')
-rw-r--r--dev-vcs/git/git-2.34.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-vcs/git/git-2.34.1.ebuild b/dev-vcs/git/git-2.34.1.ebuild
index 30f56796419f..99934132cd97 100644
--- a/dev-vcs/git/git-2.34.1.ebuild
+++ b/dev-vcs/git/git-2.34.1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi