summaryrefslogtreecommitdiff
path: root/dev-vcs/svn2git/svn2git-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/svn2git/svn2git-9999.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index c9fa2d784940..0fd35c4b742f 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils qt4-r2
-[ "$PV" == "9999" ] && inherit git-r3
+inherit desktop qmake-utils
+[[ "${PV}" == "9999" ]] && inherit git-r3
DESCRIPTION="Tool for one-time conversion from svn to git"
HOMEPAGE="https://github.com/svn-all-fast-export/svn2git"
-if [ "$PV" == "9999" ]; then
+if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/svn-all-fast-export/svn2git.git"
- KEYWORDS=""
else
SRC_URI="https://github.com/svn-all-fast-export/svn2git/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -21,24 +20,32 @@ SLOT="0"
IUSE=""
# KEYWORDS way up
-DEPEND="dev-vcs/subversion
- dev-qt/qtcore:4"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-vcs/subversion"
RDEPEND="${DEPEND}
dev-vcs/git"
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch )
+
src_prepare() {
# Note: patching order matters
- epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
- if [[ "$PV" != "9999" ]]; then
- epatch "${FILESDIR}"/${PN}-1.0.10-version.patch
+ default
+
+ if [[ "${PV}" != "9999" ]]; then
+ eapply "${FILESDIR}"/${PN}-1.0.10-version.patch
export SVN_ALL_FAST_EXPORT_VERSION=${PVR} # for src_compile
fi
+}
- qt4-r2_src_prepare
+src_configure() {
+ eqmake5 fast-export2.pro
}
src_install() {
- dodoc README.md
+ einstalldocs
insinto /usr/share/${PN}/samples
doins samples/*.rules || die 'doins failed'
dobin svn-all-fast-export || die 'dobin failed'