summaryrefslogtreecommitdiff
path: root/dev-vcs/tig
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/Manifest2
-rw-r--r--dev-vcs/tig/tig-2.5.2.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index 3be5a3a7357f..629d620135e6 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1,4 +1,6 @@
DIST tig-2.5.1.tar.gz 1144666 BLAKE2B f8e96b1e27286ebebd3e3f374b28ed31a69b10bab1e831068341a430c36418d6a412b29caa3a44e3fafb3131d93b6d8d62ade4c92dc06fe753f040957b9e64e6 SHA512 e7c27a1e6357ce3cb4c02ff409d40c0ca67d10875eedbf467b9a280d8433cca15d16860256637041003384e7c536aca743ce971e623d3000dceeda598d6d3ae0
+DIST tig-2.5.2.tar.gz 1165288 BLAKE2B 8f054f2074829b0b6b5b3b0eb533dcbd86d57ace5c12b4a5dcc32c336928889f6caf680f934c8ce12c2a27a2e6b48e7d5cee634ef936cac02ddb822b5c5b825c SHA512 9ba503d69fe52ce717bac66b4f0147b4d073cf2993083c4837b2383c6b74f5f3884e98d6f701ff1a5d434f7a898774e0243010ead0561bb119a98b52f3a10179
EBUILD tig-2.5.1.ebuild 1290 BLAKE2B 55ac7685c1797ab2de86865e5c19f4d011ab498b23fb3f91375b7017395cf60ec66e67addf8d96ebdf09926aa0d3d94cce2d4a2513ff8fc9c93e5069699a1a76 SHA512 a6f9bb48b4b7bffaad5a8475f3f75c611c91d8d50cc9f67e8cdbf307f3c293fb4e760a36dff3c7a6919b7f4eb4c90223a64c19cf9ac698f815e4ef867d971904
+EBUILD tig-2.5.2.ebuild 1363 BLAKE2B c5cb4fc150bd302db42061346eda899787223ede2438a8dc7a62329cf1e23b6f01f914471540d9e7f4cdcc6daff22887507144069cb019c52c69aa6d8accb6c5 SHA512 a7a418f340ba17c677c672e4544d11def090f0305ce41554667c5b1433aecfed2bdbb573ec1e9781650fd3e16160c7f071bedb54e0392ffce2251171c0580757
EBUILD tig-9999.ebuild 1295 BLAKE2B 1cc93adc21d1da03403dc196674871555a68f2e5ddf59d94a320dddbb5d03f4b49c6d9255cc64b6721e1bee791b86dd42f980ae5eb116c66e93345eff2d946d8 SHA512 54f2ce9cac3858d74ca03255654eaa9310de703311a7d10cb3aa9f1df66d5e89d051a810ff47648bbd6a2cd1b0b4aa8c9f00318d64b6f83dc83da31fa4e30f41
MISC metadata.xml 716 BLAKE2B 646f183cc6cc5110a69304f5343a0f1dcc9f42c82d8e16d0a06102b8052589d92bfffee948c78d2d4ce0ae6f29f1df38ae034c6fa160471823bb4457bcfa6603 SHA512 ae1521940d81aa080326f070b79a8a0a01b2ec1406088695e1e8462cdd78ce046131f9542c878ab5f919fa75e3c91aff0739a12511d18693ae050183db10343d
diff --git a/dev-vcs/tig/tig-2.5.2.ebuild b/dev-vcs/tig/tig-2.5.2.ebuild
new file mode 100644
index 000000000000..56e1d461373b
--- /dev/null
+++ b/dev-vcs/tig/tig-2.5.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/tig-completion.zsh _${PN}
+
+ dodoc contrib/*.tigrc
+}