summaryrefslogtreecommitdiff
path: root/games-action/brutal-legend
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/brutal-legend')
-rw-r--r--games-action/brutal-legend/Manifest3
-rw-r--r--games-action/brutal-legend/brutal-legend-20130615-r2.ebuild83
-rw-r--r--games-action/brutal-legend/metadata.xml26
3 files changed, 112 insertions, 0 deletions
diff --git a/games-action/brutal-legend/Manifest b/games-action/brutal-legend/Manifest
new file mode 100644
index 000000000000..dfab1cb7fd4f
--- /dev/null
+++ b/games-action/brutal-legend/Manifest
@@ -0,0 +1,3 @@
+DIST BrutalLegend-Linux-2013-06-15-setup.bin 8999631895 BLAKE2B 08b9db194412f61618f318e63b7e94fd789e84fa4c8ca695b59c6b3afc511945075cf0916a806a0af71dab093038bddda15667d75e4f100275a5ab676fb69123 SHA512 4099ed07cf78d62617eeac7de396aa01e4e9b0514861a1b0e8988f383b458281be0b3c84c33e2a2e85f80fbbacf8a4b381fc880b138af2e73a226a492cf9620a
+EBUILD brutal-legend-20130615-r2.ebuild 1761 BLAKE2B 4d4cf8d884b9f05c5e2f90e3ffc35b61ac93871e5d73a7e6c96a1e8520384d70034e75a3eb43f4c9d0eecfc66119053fd7ce2b6f4a66a4eb089743f4d5c8b5f9 SHA512 ab5598c321cd1d99b5a119c3bd3c60ad9700c9d2aeec36d388d326a467fc9dbe8271aabdca52c45fc7299e47ee3867aecad9a4bcdbc7a5011c8ddb1da8f19be6
+MISC metadata.xml 1120 BLAKE2B 075f54c7e50c918a907006c99ecb331d2cef8b848fad0313282126bd65248666f4dc74fde7c04c17216681aa281c80816633b2e92ff279b96cdaf3ddfa03232c SHA512 63b8868817c396e7708aaf65da803cd26eb1fb55fb5bdd9b0a9f92bcf0e5c6bb1a3488287949098b587991541eef6c595395fdfcecddff0b0d91a5686654a296
diff --git a/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild b/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild
new file mode 100644
index 000000000000..b9c0096e1456
--- /dev/null
+++ b/games-action/brutal-legend/brutal-legend-20130615-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: unbundle libsdl-2
+
+EAPI=6
+
+inherit eutils unpacker gnome2-utils
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="Unleash the power of Heavy Metal to reign down fire from the sky"
+HOMEPAGE="https://www.ea.com/de/brutal-legend"
+SRC_URI="BrutalLegend-Linux-${TIMESTAMP}-setup.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR="/opt/${PN}"
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Buddha.bin.x86"
+
+RDEPEND="
+ amd64? (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ )
+ x86? (
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libxcb
+
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ newicon -s 256 Buddha.png ${PN}.png
+ make_wrapper ${PN} "./Buddha.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_desktop_entry ${PN}
+
+ dodir "${MYGAMEDIR}"
+ # this is over 9000!!!! ...eh, 8GB data
+ mv * "${D%/}/${MYGAMEDIR}" || die
+
+ fperms +x "${MYGAMEDIR}/Buddha.bin.x86"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/brutal-legend/metadata.xml b/games-action/brutal-legend/metadata.xml
new file mode 100644
index 000000000000..336d0fe7cf2a
--- /dev/null
+++ b/games-action/brutal-legend/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jack Black stars as Eddie Riggs, a roadie who’s sucked into a
+ mythical Age of Rock to fight evil, liberate an army of headbangers
+ from a life of oppression, find love, and discover his life’s
+ purpose. Heavy stuff until one realizes the universe of Brütal
+ Legend has sprung up from the mind of legendary game director Tim
+ Schafer.
+
+ Enter the world of Heavy Metal where mountains are made of
+ amplifiers, killer spiders spin guitar strings, druids want to
+ kill you, and Rock Legends roam the landscape.
+
+ Armed with a massive battle-axe, guitar, and his hot-rod, Eddie
+ will rip the faces off of demons. As Eddie, expect to crush skulls,
+ ravage the road in the Deuce, and unleash the power of Heavy Metal
+ to reign down fire from the sky — all to save humanity and become
+ a brutal legend.
+ </longdescription>
+</pkgmetadata>