summaryrefslogtreecommitdiff
path: root/games-arcade/blockrage/blockrage-0.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/blockrage/blockrage-0.2.3.ebuild')
-rw-r--r--games-arcade/blockrage/blockrage-0.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/blockrage/blockrage-0.2.3.ebuild b/games-arcade/blockrage/blockrage-0.2.3.ebuild
new file mode 100644
index 000000000000..62aa1d3692a6
--- /dev/null
+++ b/games-arcade/blockrage/blockrage-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Falling-blocks arcade game with a 2-player hotseat mode"
+HOMEPAGE="http://blockrage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
+
+# Removing error due to wrong detection of cross-compile mode
+DOCS=( ChangeLog KNOWN_BUGS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-config.patch
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}