summaryrefslogtreecommitdiff
path: root/games-arcade/bumprace/bumprace-1.5.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/bumprace/bumprace-1.5.8.ebuild')
-rw-r--r--games-arcade/bumprace/bumprace-1.5.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-arcade/bumprace/bumprace-1.5.8.ebuild b/games-arcade/bumprace/bumprace-1.5.8.ebuild
new file mode 100644
index 000000000000..7ccd2496d3f4
--- /dev/null
+++ b/games-arcade/bumprace/bumprace-1.5.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Simple arcade racing game"
+HOMEPAGE="https://www.linux-games.com/bumprace/"
+SRC_URI="https://github.com/karlb/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-mixer[mod]
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ make_desktop_entry bumprace BumpRace
+}