summaryrefslogtreecommitdiff
path: root/games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild')
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild
index 70ed391a2e22..3abc29134e7f 100644
--- a/games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-1.3.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Classic overhead run-and-gun game"
HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
@@ -25,6 +25,9 @@ PATCHES=(
)
src_configure() {
+ # LTO warnings, bug #858527
+ filter-lto
+
local mycmakeargs=(
-DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/
-DBUILD_EDITOR=OFF