summaryrefslogtreecommitdiff
path: root/games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch')
-rw-r--r--games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch b/games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch
new file mode 100644
index 000000000000..92ce17bcbc39
--- /dev/null
+++ b/games-arcade/cdogs-sdl/files/cdogs-sdl-1.1.1-cmake.patch
@@ -0,0 +1,14 @@
+Remove -Werror and install data to CDOGS_DATA_DIR rather
+than directly under CMAKE_INSTALL_PREFIX.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -128,3 +128,3 @@
+ if(NOT BEOS AND NOT HAIKU)
+- add_definitions(-Winline -Werror)
++ add_definitions(-Winline)
+ set(EXTRA_LIBRARIES "m")
+@@ -195,3 +195,3 @@
+ set(LIB_EXTENSION ".so")
+- set(DATA_INSTALL_DIR ".")
++ set(DATA_INSTALL_DIR ${CDOGS_DATA_DIR})
+ endif()